Welcome, Guest
Please Login or Register.    Lost Password?

VMLite Workstation CPU utilisation and behaviour
(1 viewing) (1) Guest
Go to bottomPage: 1234
TOPIC: VMLite Workstation CPU utilisation and behaviour
#7715
VMLite Workstation CPU utilisation and behaviour 7 Years, 6 Months ago Karma: 0
Hi there,

does your VMLite workstation product properly support Intel I5 processors. The reason I am asking is that I am now doing some performance testing of my VMWare clients with VMLite workstation and have some difficulties understanding CPU behaviour in VMLite. I have an VMWare client that contains an application which takes approx. 8 minutes to start under VMWare Server with 2 CPU's assigned to the client. The application is a SAP Netweaver Java system. I have copied the system over to VMLite after I uninstalled the VMWare tools in VMWare Server. I have than create a VMLite client (Windows 2003 64-bit) and attached the vmdk's to the client. The location of the VMDK disks is the same as under VMWare. When starting the application in the VMLite client it takes more than 20 Minutes to start the same application. During this period the CPU's utilisation within the VMWare client is 100 percent. Under VMWare Server (with the max. of 2 CPU's) the utilisation never goes above 40 percent. This indicates to me that VMLite workstation either doesn't properly handles the CPU speed or something else is wrong here. The issue is definitely not related to IO. The disks performing nicely and even faster under VMLite than under VMWare. Also I have tested the application under VMLite using 2,3,4 CPU's assigned to the client and the result is the same in all three cases. The elapsed time to start the application is nearly 3 times longer than under VMWare and the CPU is mostly sitting on 100 %. Any suggestions are welcome.

Thanks.
aussie_bauer
Senior Boarder
Posts: 66
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#7717
Re: VMLite Workstation CPU utilisation and behaviour 7 Years, 6 Months ago Karma: 52
when you see 100% cpu, it's definitely not a good sign.

There are some problems with 3.2.6 for high cpu use. v4 will be better.

Is this an xp guest? can you check the task manager inside vm as how many cpus are actually running? for xp, the kernel determines # of cpu to use, even if you assign 2 cpus to the vm, it could only use one.
admin
Moderator
Posts: 2350
graph
User Offline
Gender: Male
The administrator has disabled public write access.
 
#7718
Re: VMLite Workstation CPU utilisation and behaviour 7 Years, 6 Months ago Karma: 0
As I said it is Windows 2003 (64-bit) running SQL Server 2005 and SAP Netweaver Java. Is there way that I can get VMLite workstation 4 to test this.

Thanks.
aussie_bauer
Senior Boarder
Posts: 66
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#7719
Re: VMLite Workstation CPU utilisation and behaviour 7 Years, 6 Months ago Karma: 0
Using task manager inside the client shows me exactly the number of CPU's I assigned to the client (2,3,4) depending which test I performed.
aussie_bauer
Senior Boarder
Posts: 66
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#7720
Re: VMLite Workstation CPU utilisation and behaviour 7 Years, 6 Months ago Karma: 0
Using task manager inside the client shows me exactly the number of CPU's I assigned to the client (2,3,4) depending which test I performed.
aussie_bauer
Senior Boarder
Posts: 66
graphgraph
User Offline Click here to see the profile of this user
The administrator has disabled public write access.
 
#7721
Re: VMLite Workstation CPU utilisation and behaviour 7 Years, 6 Months ago Karma: 52
you may want to change the acceleration settings, turn off nested paging, etc.
admin
Moderator
Posts: 2350
graph
User Offline
Gender: Male
The administrator has disabled public write access.
 
Go to topPage: 1234